Author Topic: MP4 file stops playing in middle  (Read 16791 times)

gseifert

    Reputation: 2
MP4 file stops playing in middle
« on: November 29, 2011, 08:53:07 pm »
November 29, 2011, 08:53:07 pm
This happened at home and now at work.  The mp4 file appears to be complete but just stops playing about half way thru it.

Re: MP4 file stops playing in middle
« Reply #1 on: November 29, 2011, 09:34:19 pm »
November 29, 2011, 09:34:19 pm
And you have tested this MP4 in various media players, eg, Windows Media Player, VLC Player and QuickTime Player?

gseifert

    Reputation: 2
Re: MP4 file stops playing in middle
« Reply #2 on: November 30, 2011, 12:01:42 am »
November 30, 2011, 12:01:42 am
I think the general consensus here is that my machine is the only one that can handle the HD video.  When playing on all others the vid just freezes.  It was freezing on my machine too until I put more key frames in place on the video....Does this sound right?  Would HD do that?  I'm new to the animation end of this.

Re: MP4 file stops playing in middle
« Reply #3 on: November 30, 2011, 10:11:02 am »
November 30, 2011, 10:11:02 am
Did you render the MP4 in Lumion or in a 3rd party video editor?

gseifert

    Reputation: 2
Re: MP4 file stops playing in middle
« Reply #4 on: November 30, 2011, 04:21:39 pm »
November 30, 2011, 04:21:39 pm
Entirely in Lumion.  In fact I just posted it to You tube and it works fine.  Here's the link:    this was a quick and dirty trial with a SkUP import just to see what the new graphics card would do.  I'm really interested in solving this as our clients don't usually have monster grahic cards or gaming pcs to play these high res vids.

I tried running this thru handbrake also with no luck.  As I'm new to the video aspect of this any suggestions are welcome.

Gaieus

    Reputation: 44
Re: MP4 file stops playing in middle
« Reply #5 on: November 30, 2011, 05:01:15 pm »
November 30, 2011, 05:01:15 pm
Fossa, can you upload the original video somewhere and share the link here (I guess it's too large for a direct attachment). Maybe we could also have a look and decide if your client needs a serious hardware update (my machine is not a killing one either)

gseifert

    Reputation: 2
Re: MP4 file stops playing in middle
« Reply #6 on: November 30, 2011, 06:17:02 pm »
November 30, 2011, 06:17:02 pm
Gaieus:

I have emailed you at your sketchucation email with a username and password to our ftp site.

Gaieus

    Reputation: 44
Re: MP4 file stops playing in middle
« Reply #7 on: December 01, 2011, 10:44:38 am »
December 01, 2011, 10:44:38 am
Yes, and I answered that the only thing you did not email is the ftp site address :)

(Anyway, hope to see it soon: if it turns out to play on most machines, there may be something on that particular machine to fix).

gseifert

    Reputation: 2
Re: MP4 file stops playing in middle
« Reply #8 on: December 01, 2011, 03:05:00 pm »
December 01, 2011, 03:05:00 pm
I just emailed you with the address.  Sorry about that.

Gaieus

    Reputation: 44
Re: MP4 file stops playing in middle
« Reply #9 on: December 01, 2011, 05:34:06 pm »
December 01, 2011, 05:34:06 pm
No problem at all.

Well, I could download the video file and play it all along its 2:15 length. My computer is not very impressive (2.5 years old, dual core @ 3 GHz, 4Gb RAM but on a 32 bit system and an nvidia geforce 9600 GT @ 1Gb)

So I do not know what causes it to stop on your client's computer.

Re: MP4 file stops playing in middle
« Reply #10 on: December 05, 2011, 12:01:52 am »
December 05, 2011, 12:01:52 am
Not sure if this will help, or you may have tried, but if the videos data rate (kbps) is too high some video players will not be able to fully or properly play the video.

Lumion output to mp4 is a variable bit rate (from what I can tell), so depending on the scene and render requirements it can produce video up to 20000 kbps (usually at the 3 Star setting), which some players will just not handle correctly.  For example, I have some clips 10000 to 15000 kbps that VLC drops the frames, especially ending frames but it plays perfectly fine and smooth in WMP.

YouTube videos get reconverted and seem to be no more than about 5000kbps.

You can try rendering in 2 Star which will be a lower final kbps but may not be the quality you desire, or use a simple video conversion or editing tool to lower the kbps (will affect quality also, quick to reconvert though).

gseifert

    Reputation: 2
Re: MP4 file stops playing in middle
« Reply #11 on: December 05, 2011, 03:53:30 pm »
December 05, 2011, 03:53:30 pm
I think that may be the case.  I can run it thru handbrake on the ipad settting and get it play on an ipad, but still have problems with it on pc's.  It really seems to choke when trees are in the shot.  That makes sense to me because of all leaf textures.

I'm still new to this video end of things, if anyone could suggest some good books or websites on video conversions and manipulations, bit rates, etc. I'd appreciate it.  Until then I guess it's just a matter of playing with the settings and trying to find a good compromise.

Re: MP4 file stops playing in middle
« Reply #12 on: December 05, 2011, 11:07:22 pm »
December 05, 2011, 11:07:22 pm
There's a topic on video editors here that might be of use.

Of course check first though that the video codecs are up to date.  The fact that Gaieus was able to properly play your original video suggests maybe the other PC's just don't have the grunt (CPU, mthboard) to read the high kbps but iss why they can for the YouTube.


gseifert

    Reputation: 2
Re: MP4 file stops playing in middle
« Reply #13 on: December 06, 2011, 03:03:23 pm »
December 06, 2011, 03:03:23 pm
Thanks, that looks good and the price is right.

Thomas

    Reputation: 4
Re: MP4 file stops playing in middle
« Reply #14 on: December 08, 2011, 10:20:46 am »
December 08, 2011, 10:20:46 am
I experienced the same problem, mp4 files stop playing in VLC player, but work fine in WMP. Stops during playing on my Toshiba TV, but works perfect with my Samsung. There seems to be a compatibility problem with the mp4 files.