Author Topic: Going Crazy with render times ! 40 Seconds and 90 Seconds per frame !  (Read 1928 times)

July 10, 2012, 11:24:26 am
Hello,

I used to have an issue with Lumion 1 before that caused my render times to reach 25 Seconds, Back then I was still a "newbie" with the whole Real Time rendering stuff and I really noticed that most of my models were not optimized for such engines, for example a soccer field had no more than 500 polies yet the 2 Goals with their nets were over 350,000 Polies each !

I am revisiting and old project That I created with Lumion, as the first was a fast rough job to finish on deadline but now I have more time on my hands to smooth things out.

My PC setup is :
Intel Core i7 950 @ 3.07 GHZ
8.0 GB DDR3 Rams
ATi Radeon 6950 1GB DDR5


I've redone most of the model from scratch ... to suit Lumion. I've even seperated the buildings from the rest of the model thanks to the excellent (20+ layer plus feature of lumion 2)

the base model without the buildings is around 250,000 Polies 137K Verts as Lumion prefers it.


which without any props (people/cars/objects) or trees, only texutred in lumion renders a frame in 3.94 Seconds ! Which is very nice ! Lumion reads 193K not 137K but thats ok ...

Sadly after turning on all the props/trees the verts rise from 193k to 5652K !
I thought the trees were adding up, but apparently it was the props !(vechiles/people/objects) they add alone almost 3000K of verts !
render time for the base model + lumion props + trees doubled to 7.6 Seconds !


now turning on my props (goals/lights/other misc stuff.. ) jumps the verts from 5625K to 9000K
Render times goes up tp 9.2 Seconds.

sadly .. turning on the optimized buildings and everything else .. the verts jumped from 9000K to 16754K, Render times jumps to 12 Seconds.

Which is still super fine with me ! for a scene this complex ... my problem is after a few renders from almost the same view .. or after a couple of hours of work ..

Render times seems to escalate even for the same scene .. for example the same scene without adding anything .. after a few hours of moving stuff around or pllaying with the camera .. renders in about 30 seconds ...

A night version with lumion lights renders at first in 25 - 35 seconds per frame then jumps to 90 frame per second !

is there something wrong with my gfx card ? or is it something known in Lumion that after a few hours of GPU load, FPS beings to suffer ?

for example the same scene I rendered in 12 Seconds, Rendered in 32 Seconds before Restarting the Computer !

What am I doing wrong ?

and is 16000K Too much for Lumion or Too much for a scene like this :


Note: My gfx card is updated to latest Catalyst Drivers and every component of the PC is up to date.

Thanks.




July 10, 2012, 11:43:26 am
Update: I've asked one of the IT people to check my PC, Apparently my Lumion is a bit out of date as there's a new version (2.5) out but still not updated (I can not install it because I have no admin rights) I've asked for them to set it up for me today.

Will it make any differences ?

I also would like to know how to add icons and my version of lumion next to my avatar/forum icon.
Thanks.

July 10, 2012, 07:19:09 pm
Hi cryptonx, your graphics card isn't among the fastest out there and 1gb ram isn't much for a scene with that many vertices, but it's not an utterly hopeless card either:
http://www.videocardbenchmark.net/gpu.php?gpu=Radeon+HD+6950

Updating to 2.5 is a good idea, and so is restarting Lumion before you start rendering very complex scenes; this will minimise memory consumption.

About night-time scenes with artificial light sources and how to reduce render times, please read this excerpt from another post:



Shadow Cache off:
The shadows are updated every frame (Slow!)

128:
The shadow from the light uses a static 128x128 pixel texture (Fast, very low memory usage)

256:
The shadow from the light uses a static 256x256 pixel texture (Fast, low memory usage)

512:
The shadow from the light uses a static 512x512 pixel texture (Fast, moderate memory usage)
______________________________

Every time you add a light with "Shadow Cache off", the entire scene has to be rendered once more. Add 10 lights and the scene has to be rendered 10 times more every frame.

So if you make some of the lights use static shadows (e.g. the 512x512 pixels option) the graphics card has to render the scene fewer times per frame at the expense of slightly higher memory usage. This will almost always result in shorter render times and better performance.

The downside is that the shadow texture is a lower resolution than those of dynamic shadows (2048x2048 per light).

SUMMARY:
To reduce render times, we recommend that you turn distant lights (e.g. street lights) in your scene into lights with static shadows (so that the shadows are not updated every frame). If your graphics card has enough RAM, the best option is "512".

You would only ever use "Shadow Cache off" for your lights if:

  • Something that casts shadows is moving near the light (a car driving past a street light for example).
  • The light itself moves/rotates (stage lighting for concerts for example).
  • You need high-resolution shadows in certain areas (typically close-ups of interiors).

July 12, 2012, 11:56:39 am
Thanks alot Morten,

I always forget the Shadow Cache setting,I had 67 lights :) the scene was being rendered 67 times each frame ! OMG

As for the rest of the model I managed to bring down the Rendertime to 8.9 Seconds with everything turned on and I overclocked the GPU :)

Decided to buy a new one thinking of the 6990.


Thanks again.

July 12, 2012, 12:06:12 pm
Good to hear that - 8.9 seconds per frame is much better!

By the way, your questions inspired me to post some tips on how to reduce render times:
http://lumion3d.com/forum/f-a-q/how-to-reduce-render-times-in-lumion/