Author Topic: flickering  (Read 2238 times)

sathisharchian

    Reputation: 0
flickering
« on: November 14, 2011, 06:00:49 am »
November 14, 2011, 06:00:49 am
why is this flickering coming and how to avoid it.....i changed the depth offset but its still ending up like this... in photo mode its somewhat OK...but in video render the flicker is dominating....please help me to avoid it...

Pete Stoppel

    Reputation: 33
Re: flickering
« Reply #1 on: November 14, 2011, 06:43:11 am »
November 14, 2011, 06:43:11 am
Looks like you have two planes occupying the same position.

Noire

    Reputation: 5
Re: flickering
« Reply #2 on: November 14, 2011, 07:18:08 am »
November 14, 2011, 07:18:08 am
yep. this is double faces. check geometry carefully before export/import to Lumion.

Re: flickering
« Reply #3 on: November 14, 2011, 11:07:09 am »
November 14, 2011, 11:07:09 am
Excerpt from other threads:

Polygons that flicker when they're close to each other (Also known as z-fighting) are caused by the lack of accuracy in real-time 3D, and is present in most 3D engines/modellers that I know of. The bigger the world is and the further away from 0,0,0 you are, the more prevalent the problem is (It's essentially caused by only having 8 digits for polygon positions at our disposal).

1) Depth Offset: If you're doing a real-time walkthrough, you should apply a Lumion material to the flickering surface and adjust the "Depth Offset" slider for the material just enough to get rid of the flickering (press shift while adjusting the slider to do this more accurately).

2) Camera Clip Planes: If your output is a movie clip, there's a very effective way of getting rid of flickering polygons. In the Movie editor, select the clip followed by New effect -> Scene effects -> Camera Clip Planes. Adjusting the "Near" plane slider should eliminate the flickering completely in that clip. If your camera moves around a lot during a clip you will often have to animate the "Camera Clip Planes" effect. Move the time slider to a place where you notice flickering, adjust the "Near plane" slider until the flickering is gone and click on the small circular button to the right of the slider to set a keyframe.

The rule of thumb is that the closer the "Near plane" is to the eye position and the greater the distance between the "Near" and "Far" camera clip planes is, the more z-fighting you're likely to encounter.

In real-time 3D, the distance where z-fighting begins to occur also depends on the distance from the camera to the polygons in question. If the polygons are close to the camera, z-fighting only occurs when the polygons are, say 1mm from each other while at a distance of 2km from the camera it occurs when polygons are, say within 1m of each other.

Gilson Antunes

    Reputation: 108
Re: flickering
« Reply #4 on: November 14, 2011, 12:53:52 pm »
November 14, 2011, 12:53:52 pm
Hello Morten, I tested this option in item 2 of my scenes and works perfectly.
Thanks for the tip. :-D :-D

Re: flickering
« Reply #5 on: November 14, 2011, 07:03:25 pm »
November 14, 2011, 07:03:25 pm
@sathisharchian
Could you post your scene (on only the part with flickering issue)?
We are developing mechanism to avoid this issue automatically, and it will be good test.

sathisharchian

    Reputation: 0
Re: flickering
« Reply #6 on: November 15, 2011, 09:07:09 am »
November 15, 2011, 09:07:09 am
thanks for your reply....
i have changed the clip plains .... but if seen from closer its ok but if the camera is far it ends up like flickering
i am  attaching the lumion file which i am working....the whole file is very big and is made of many parts ...so i am uploading the part from it....

sathisharchian

    Reputation: 0
Re: flickering
« Reply #7 on: November 15, 2011, 09:09:03 am »
November 15, 2011, 09:09:03 am
the two planes are touching from inside .....but the roof slab is seen on the outer side of te building....

Re: flickering
« Reply #8 on: November 15, 2011, 09:30:32 am »
November 15, 2011, 09:30:32 am
Thank you for files.
Could you post source file too (for example DAE or FBX)? If it is too big then send only one building with flickering problem.

Thanks in advance,

sathisharchian

    Reputation: 0
Re: flickering
« Reply #9 on: November 15, 2011, 12:17:06 pm »
November 15, 2011, 12:17:06 pm
@Artur Brzegowy
thanks for reply....
i am sending the source .dae file. i cannot send the whole model as its too big city model nearly 450mb so only sending a part file..
its not only the portion which i showed you is flickering....
most of the model is flickering if the camera is far... when the camera is near its ok...
i am also sending the video file for your reference..hope you can help me before the final presentation..
thanks in advance...

Re: flickering
« Reply #10 on: November 15, 2011, 12:45:42 pm »
November 15, 2011, 12:45:42 pm
thanks for your reply.... i have changed the clip plains .... but if seen from closer its ok but if the camera is far it ends up like flickering

To solve this problem, you'll need to animate the "Camera Clip Planes" effect when the camera is far away from the buildings. Move the time slider to a place where you notice flickering, adjust the "Near plane" slider until the flickering is gone and click on the small circular button to the right of the slider to set a keyframe.

sathisharchian

    Reputation: 0
Re: flickering
« Reply #11 on: November 15, 2011, 01:48:01 pm »
November 15, 2011, 01:48:01 pm
@ mortein
thanks for your help
i tried to change the clip planes... but its not working....i am attaching the screen shot of the work...
if i am wrong, is there any tutorial for changing the clip planes..

Re: flickering
« Reply #12 on: November 15, 2011, 02:57:37 pm »
November 15, 2011, 02:57:37 pm
Since the roof polygons are more or less co-planar with the rest of the building, you will experience flickering when the camera is further away.

Assuming that you have applied a Custom material to the roof, you'll need to check the "Depth Offset" slider of the roof material. You should never use extreme slider values, but just enough to make the roof stop flickering in Build mode, when the camera is a fair distance away from the buildings.



Then go to Movie mode and animate the "Near Plane" in the "Camera Clip Planes" effect as described above.

If you are still experiencing problems, consider moving the co-planar polygons a little in your modelling application.

rhino3dman

    Reputation: 0
Re: flickering
« Reply #13 on: February 09, 2012, 09:11:16 pm »
February 09, 2012, 09:11:16 pm
I also noticed some tiling effect on the textures and shadows when rendering distant view. How do I improve the seamlessness of the textures and aliasing of shadows?

Re: flickering
« Reply #14 on: February 10, 2012, 11:08:58 am »
February 10, 2012, 11:08:58 am
I also noticed some tiling effect on the textures and shadows when rendering distant view. How do I improve the seamlessness of the textures and aliasing of shadows?

Can you post some renderings so we know what you mean?